trensim.comSimulación Ferroviaria
   

Problema con Bogie

Foro de ámbito general para temas de Trainz

Moderador: Moderadores

Problema con Bogie

Notapor Mono_Shadow » Lun Dic 21, 2009 11:52 pm

hola a todos...... resulta que hace poco termine un bogie para mis carros de carga..... todo bien..... la animacion, las texturas....
he incluso al jugar en TRS2006 en modo DCC...... ningún problema......
el problema viene cuando lo hago en modo cabina..... resulta que las ruedas.... no dan vuelta... estan quietas como los bogies del Trainz 1.1

Imagen

espero que me puedan ayudar......
tengo el TRS2006 3337

Saludos
Imagen
"El sur no tiene partes aburridas... es todo muy hermoso, muy bonito"
Avatar de Usuario
Mono_Shadow
 
Mensajes: 108
Registrado: Sab Nov 11, 2006 11:57 pm
Ubicación: Santiago de Chile

Re: Problema con Bogie

Notapor Kaur » Jue Dic 31, 2009 3:50 pm

As puesto en el config en animdist?
Jordi (Kaur) Web Master
Imagen
El silencio es el único, que jamás traiciona. Pero no hablar también lo hace.
Avatar de Usuario
Kaur
 
Mensajes: 903
Registrado: Vie Oct 21, 2005 12:30 pm

Re: Problema con Bogie

Notapor Mono_Shadow » Jue Dic 31, 2009 8:17 pm

eeemm........ si..... si le puse el animdist....... pero no se si me faltara algo....

aqui esta el config

Código: Seleccionar todo
kuid                        <kuid:309439:5001>
kind                            "bogey"
category-class                      "ZB"
category-region                 "CL"
category-era                 "1900s;1910s;1920s;1930s;1940s;1950s;1960s;1970s;1980s;1990s;2000s;2010s"
trainz-build                 2.5
direct-drive                 1
animdist                    2.84
mesh-table {
   default {
      mesh               "bogie_elecmetal.im"
      auto-create            1
   }
}
obsolete-table {
}
kuid-table {
}


le borre los datos mios y de licencia que por el momento..... no importan :wink:

Saludos y espero ayuda
Imagen
"El sur no tiene partes aburridas... es todo muy hermoso, muy bonito"
Avatar de Usuario
Mono_Shadow
 
Mensajes: 108
Registrado: Sab Nov 11, 2006 11:57 pm
Ubicación: Santiago de Chile

Re: Problema con Bogie

Notapor camber » Vie Ene 01, 2010 4:06 am

Hola,

No entiendo de material rodante, pero me llama la atención que no declaras la animación del bogey en el config.txt. Esto es obligatorio para el resto de objetos animados en Trainz. Es el archivo .kin que se exporta desde Gmax o 3DS Max. Algo así como esto:

mesh-table
{
default
{
mesh "mi_bogie.IM"
anim "anim.kin"
animation-loop-speed 1
auto-create 1
}
}

Tal vez alguien más experto en este tema te lo pueda detallar.
Saludos
Avatar de Usuario
camber
 
Mensajes: 114
Registrado: Mar Ene 24, 2006 4:26 pm

Re: Problema con Bogie

Notapor Mono_Shadow » Vie Ene 01, 2010 4:48 am

camber escribió:Hola,

No entiendo de material rodante, pero me llama la atención que no declaras la animación del bogey en el config.txt. Esto es obligatorio para el resto de objetos animados en Trainz. Es el archivo .kin que se exporta desde Gmax o 3DS Max. Algo así como esto:

mesh-table
{
default
{
mesh "mi_bogie.IM"
anim "anim.kin"
animation-loop-speed 1
auto-create 1
}
}

Tal vez alguien más experto en este tema te lo pueda detallar.
Saludos


el problema con el anim.kin..... y el "animation-loop-speed"...... es que ta lo probe..... pero es peor el resultado con esa configuracion en el config.....

ahi el bogie esta dando vueltas y vueltas mientras que la composicion esta totalmente parada :x

ahi si que no se como aplicar el "animation-loop-speed"............

saludos
Imagen
"El sur no tiene partes aburridas... es todo muy hermoso, muy bonito"
Avatar de Usuario
Mono_Shadow
 
Mensajes: 108
Registrado: Sab Nov 11, 2006 11:57 pm
Ubicación: Santiago de Chile

Re: Problema con Bogie

Notapor portu » Sab Ene 02, 2010 2:33 pm

A mi me paso lo mismo cuando trate de convertir los bogies de la 253 a TS2009 o bien se quedaban dando vueltas continuamente o si suprimia el "animation-loop-speed 1" o lo modificaba se quedaba sin animación.....con lo cual lo importe a TS2009 con la misma configuración que tenia en Tr2004 osea esta....



kuid <kuid:297088:2530>
category-region-0 "ES"
category-era-0 "2010s"
category-class "AC"
trainz-build 2
animdist 4.1
mesh-table {
default {
mesh "253_bogey.IM"
anim "ANIM.KIN"
auto-create 1
animation-loop-speed 1
}
}
obsolete-table {
}
asset-filename "253_bogey"
username "253_bogey"
author "Portu"
organisation "Trainzportu"
contact-email "aportu@msn.com"
contact-website "http://www.spaintrainzrutas.com/"
license "CONDICIONES PARTICULARES DEL ADD-ON (LICENCIA)
CONDICIONES DE DISTRIBUCION:

- Esta addon es de distribucion COMPLETAMENTE GRATUITA (freeware)
- Este addon ha sido creado por STR, y su distribucion original es a traves de STR

CONDICIONES DE USO:


- Queda prohibida la utilizacion total o parcial de esta addon para la elaboracion de otros repintados sin el consentimiento de los autores y sin mencionar expresamente a los mismos.
- Queda prohibida cualquier utilizacion comercial de cualquier tipo de este addon, sin el consentimiento expreso y por escrito de los autores.
- Este addon se ubica para su libre descarga sin ninguna garantia de uso y funcionamiento

La instalacion y ejecucion de este addon implica la aceptacion de estas condiciones de uso.
"
kuid-table {
}
kind "bogey"


....y ahora funciona sin problemas,no se si te habre ayudado pero quizas podrias probar esta misma configuracion cambiando ,logicamente,los kuids y los nombres de las mallas y probar.

Saludos.

Portu
https://trainzportu.blogspot.com.es/
Imagen
Avatar de Usuario
portu
 
Mensajes: 862
Registrado: Sab Mar 29, 2008 12:30 am

Re: Problema con Bogie

Notapor Mono_Shadow » Sab Ene 02, 2010 10:14 pm

aplique esas nuevas configuraciones....... pero volvimos al mismo problema que en el principio.......

en modo DCC........ los bogies animan sin niun problema.......
en modo cabina..... quedan parados sin animacion aun estando en movimiento el tren

Código: Seleccionar todo

kuid                     <kuid:309439:5001>
kind                     "bogey"
category-class                  "ZB"
description                  "Bogie Elecmetal para toda la flota de carros de carga de la empresa FEPASA"
username                  "Bogie Elecmetal"
author                     "Yerko Meneses (Mono_Shadow)"
organisation                  "KLaN_Mono"
contact-email                  "yerkomeneses@gmail.com"
contact-website                  "http://viasur.4t.com"
license                     "
LICENCIA DE USO
--------------------------------------------
1 PROHIBIDA LA MODIFICACION DE CUALQUIER FICHERO RELACIONADO CON ESTE PRODUCTO SIN TENER PREVIO CONSENTIMINETO POR ESCRITO DEL AUTOR.

2 PROHIBIDO EL USO DE TECNOLOGAS INVERSAS PARA LA MANIPULACION DE CUALQUIER FICHERO.

3 EL USUARIO SE HACE RESPONSABLE DE CUALQUIER DAÑO QUE PUEDA CAUSAR EL MAL USO DE ESTE PRODUCTO.


LICENCIA DE DISTRIBUICION
--------------------------------------------
1 ESTA PROHIBIDA LA DISTRIBUCION DE CUALQUIER FICHERO RELACIONADO CON EL PRODUCTO POR SEPARADO.

2 ESTA PROHIBIDA LA DISTRIBUCION EN REDES DE TIPO PEER2PEER COMO PUEDEN SER KAZAA, EDONKEY, EMULE, ETC.

3 ESTA PROHIBIDA LA DISTRIBUCION DE ESTE PRODUCTO EN PAGINAS QUE DEN PROVILEGIOS A LOS USUARIOS QUE PAGAN UNA CUOTA.

4 ESTA PROHIBIDA LA DISTRIBUCION DE ESTE PRODUCTO BAJO CUALQUIER FORMATO FISICO COM PUENDEN SER cD-ROMS, DVD-ROM, DISQUETES, ETC.

5 ESTA PROHIBIDO EL USO O DISTRIBUCION DE ESTE PRODUCTO O SUS IMAGENES RECIBIENDO UNA COMPENSACIN ECONoMICA A CAMBIO.
-----------------------------------------------------------------'"
category-region                  "CL"
category-era                  "1900s;1910s;1920s;1930s;1940s;1950s;1960s;1970s;1980s;1990s;2000s;2010s"
trainz-build                  2
direct-drive                  1
animdist                  4.1
mesh-table {
   default {
      mesh               "bogie_elecmetal.im"
      anim               "anim.KIN"
      animation-loop-speed         1
      auto-create            1
   }
}
obsolete-table {
}
kuid-table {
}


ahi ta el config cambiado...... mmm..... me esta colmando la paciencia :evil:

Saludos
Imagen
"El sur no tiene partes aburridas... es todo muy hermoso, muy bonito"
Avatar de Usuario
Mono_Shadow
 
Mensajes: 108
Registrado: Sab Nov 11, 2006 11:57 pm
Ubicación: Santiago de Chile


Volver a Trainz

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 3 invitados